Building the Coming Soon

关于

HFLS aka the Akademia 12′, then NJUST 16′, now HKU.

Firefox

Ubuntu系统更换Firefox桌面图标方法

08/10/2013

终于,在升级到Firefox 23.0之后,Kaijia的Unity启动栏中出现了第一个被“拍扁了”的图标——火狐。这个新Logo在Unity启动器上只能用惨不忍睹来评价了:

Unity启动器中Firefox新旧图标比较

Unity启动器中Firefox新旧图标比较

上一篇博文中Kaijia已经吐嘈过如何将Firefox降级到22.0版本了,但是不升级终究不是个好办法,并且Ubuntu没有提供Firefox 17.0 ESR(长期支持版本)的更新,所以升级到新版本的Firefox是不可避免的。于是Kaijia想到了一个办法,用旧版本的Firefox图标在Unity启动器中替换掉这个破坏整体感觉的新图标,这样就可以实现用的是Firefox 23.0但任务栏中显示的还是旧版的Firefox了。

阅读更多

Ubuntu系统降级Firefox至22.0方法

08/09/2013

今天Kaijia程序写到一半,突然跳出Ubuntu更新管理器提示更新Firefox,于是升级了一下Firefox至23.0,结果这一升级遇到了各种大为郁闷的问题。首先是图标,之前Mozilla博客中曾经提到过的,Firefox 23.0将会更换新的扁平化设计图标,今天看到这个图标后可以说,在Unity边栏上简直就是惨不忍睹。更郁闷的一点是,相信是插件没有更新存在兼容性问题,导致新版本的Firefox非常卡。于是Kaijia果断决定将Firefox降级回22.0版本。

Kaijia查找了一些apt-get的资料,发现apt-get的确支持软件降级,但是尝试之后发现apt-get无法将Firefox降级到22.0版本(apt-cache中只能查看到11.0和最新的23.0版本,分别来自两个不同的源)。Kaijia使用新立得强制安装,发现也只能选择两个版本。

Synaptic仅显示两个可用版本

Synaptic仅显示两个可用版本

阅读更多

Firefox不信任StartSSL证书问题解决

08/22/2012

StartSSL证书的支持率一直是一个很大的问题,今天在Apache中安装完StartSSL证书之后遇到了以下情况:

  • Firefox提示“此连接是不受信任的”,同时Opera则在地址栏左侧状态中提示“服务器试图应用安全措施,但没有成功”;
  • 桌面版本Chrome显示已经加密,但iOS版Chrome则提示“此网站尚未经过身份验证。”;
  • Win7下IE9和iOS版本Safari都显示已经加密。

理论上讲,StartSSL支持除了Opera外所有的主流浏览器,因此Firefox遇到的不受信任的连接是不正常情况。

经过查看官网文档和Google后找到了问题的原因:Firefox仅包含了StartCom的根证书,而中间证书需要服务器提供,一般网上的Howto都不会提及这一点,所以会出现类似问题。

阅读更多

... 载入更多文章 ...

- 已经载入全部文章 -